Ultimatte Software Sales and Information

Plugin Description
Contact Us
Frequently Asked Questions
AdvantEdge Brochure
AdvantEdge and RT User Manual
Compatible Editing Apps
Blue / Green Screen Samples
Purchase Ultimatte AdvantEdge or Ultimatte RT
direct from the lowest-priced Authorized Reseller

Download Ultimatte AdvantEdge and Ultimatte RT Plugin:

 

      The dowloaded Ultimatte AdvantEdge plugin will work the same as the full version, except the free version will have watermarks over all of the composited content.  When you purchase the plugin, there is no need to re-install.  Simply attach the USB dongle (looks like a small USB flash drive).  When the dongle is plugged into the USB port on computer, the watermarks will not be there.

 

For WindowsClick here to download the Windows plugin.

  • Adobe PhotoShop v5.5 to CS4
  • Adobe After Effects v5.0 to CS4
    Adobe Premiere v6 or higher (Premiere Pro compatibility coming soon)
    Autodesk Combustion v1.2 or higher
    Avid - All Windows products supporting AVX v1.5
    Avid DS 6, 7 and 8 (32-bit only)
    Eyeon Digital Fusion v3.12 or higher
    * Not yet compatible with the Adobe CS5 applications.  E-mail to be notified when AdvantEdge is available for CS5.

 

For Mac OS XClick here to download the Mac plugin.

  • Adobe Photoshop v7.0 to CS4
  • Adobe After Effects v5.5 to CS4
  • Apple Shake v.3.5 or higher (including v4)
  • Avid - All AVX products supporting AVX v1.5
  • Apple Final Cut Pro v5.0 or higher
  • Autodesk Combustion v2.0.1 or higher
  • media 100i v8.0 or higher
  • media 100 sw v10.2 or higher  
  •       This download includes the Ultimatte RT (GPU-accelerated FxPlug) for:
  •                Apple Final Cut Pro
  •                Apple Motion
  • * Not yet compatible with the Adobe CS5 applications.  E-mail to be notified when AdvantEdge is available for CS5.
  •  

For Red Hat Linux:  Click here to download the Red Hat Linux plugin.

  • Apple Shake v3.5

 

For SGI IRIX:  Click here to download the SGI IRIX plugin.

  • Autodesk - Flame, Inferno, Fire, Smoke, and Flint supporting Discreet SDK v4.0/7.0 or higher (32-bit only)

 

Purchase Ultimatte AdvantEdge or Ultimatte RT
direct from the lowest-priced Authorized Reseller

Contact us for more information!

Ultimatte is a registered trademark of Ultimatte Corporation.
Ultimatte-Software.com is operated by an Ultimatte Authorized Reseller.
All content ©2007-2010 Ultimatte Corporation or Virtualsets.com, Inc.  All rights reserved.